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Abstract

We describe BugView, a cross-platform application for presenting and comparing the genomes of bacteria or eukaryotes. We give particular emphasis to its use in comparing the genes of related bacterial genomes, and consider different methods of automating the preparation of genome comparison files, including a new web-based facility. Ways of using BugView to study and present the internal structure of genomes are also discussed. BugView/weB, a Java applet for web deployment of BugView files, is presented for the first time.
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1. Introduction


BugView is a desktop computer program, designed to allow users to visualize and compare pairs of bacterial genomes (1). It uses Genbank files, publicly available from the NCBI FTP site, as a source of genome data; and it incorporates comparison functions employing dynamic programming. The program is free and cross-platform: versions are available for Mac OS 8/9, Mac OS X, Windows 95 to XP, and Unix/Linux. 

BugView is not restricted to displaying bacterial genomes: it can handle introns, and so can also be used with eukaryotic genomes. Nor is there anything to prevent it being used to display and edit single genomes, either individually or together in the same window. However this chapter concentrates, for the most part, on describing how to use BugView with pairs of related bacterial genomes—its primary purpose. It describes how to download the required data files, how to create a special comparison file that stores the relationships between the genes of the two genomes, how to navigate and edit the displayed comparison, and how to export particular views of a genome comparison. 

This is followed by a section that considers the visualization and presentation of genes within the genome, in particular the arrangement of genes belonging to similar functional categories,

A final section describes how to display one’s own BugView comparisons on the web using a special version of the program (a Java applet).

2. Software and Data Files

2.1 BugView

At the time of writing the latest version of BugView is 1.3.3 (released March 2006), which supercedes all previous versions. It contains some small bug-fixes and usability improvements compared with the previous version and is recommended for all users.

2.1.1 Downloading and installing BugView

1.
Connect to http://www.gla.ac.uk/~dpl1n/BugView/bvdownload.html (or alternative: see Note 1).

2.
Click on the link for the operating system of your computer, and the file will be downloaded.

3.
You should also download the Manual, and may wish to download the Sample files on the same web page.

4.
The files are in different compressed formats for each platform, and, if they do not decompress automatically, may be compressed with the following utilities: Mac OS8/9 (.sit)—Stuffit, Mac OS X (.dmg)—double-click to open the disc image, Windows (.zip)—Winzip, Unix/Linux (.tar.Z)—uncompress, followed by tar xvf.

5.
For Mac and Windows, just drag the uncompressed executable program to a location of your choice; for Unix/Linux the program is in the form of a file, BugView.jar, which should be placed in the same location (most conveniently one in your ‘path’) as a supplied shell script bugview.sh. For Mac OS8/9 you are advised to rebuild your desktop to ensure the application and files acquire the correct icons.

6.
The Mac and Windows versions are launched by double-clicking the BugView icon; the Unix/Linux version is launched by running the shell script, bugview.sh.

2.1.2 Hardware requirements

To run BugView a machine with a processor speed of at least 500 MHz — extremely modest by contemporary standards — is recommended, although the performance of the sequence-comparison functions within BugView is appreciably enhanced on machines with faster processors. The free RAM requirement is more difficult to quantify, but on older machines insufficient RAM can limit the size of genome file that can be loaded (see Note 2).

2.1.3 System software requirements

BugView is a Java program and requires an operating system-specific version of the ‘Java Virtual Machine’ to run. The situation for different operating systems is summarized below.

2.1.3.1 Mac OS8/9

MRJ (Mac Runtime for Java) is part of the Mac OS 8 or OS 9 installation. The last standard version of this for classic Mac, MRJ 2.2.5, can be downloaded using the Software Update control panel.

2.1.3.2 Mac OS X

Apple’s version of the Java Virtual Machine is part of the Mac OS X installation. However, as of Mac OS 10.4, the default version of Java is 1.4, with the latest version (1.5) an optional download. Although Java 1.5 is not needed for the basic functionality of BugView, it is required to overcome one specific OS X ‘bug’ (see Note 3).

2.1.3.3 Windows

Some versions of Windows shipped with Microsoft’s limited version of the Java Virtual Machine, which, nevertheless, should be adequate to run BugView. Later versions did not, in which case the latest version of Java for Windows can be downloaded from Sun Microsystems’ website (http://java.sun.com/).

2.1.3.4 Unix/Linux

A Java Virtual Machine is installed with Sun’s Solaris operating system, but may not come with other flavors of Unix, in which case a version can be downloaded from Sun’s website (http://java.sun.com/).

2.2 Genbank Files

Bacterial genome files are available from NCBI (National Center for Biotechnology Information). They are actually held on the NCBI FTP site at ftp://ftp.ncbi.nih.gov/genomes/Bacteria/. This gives an alphabetical listing of completed genomes with links to download pages for individual entries. Alternatively the files can be accessed via the website, currently from http://www.ncbi.nlm.nih.gov/genomes/lproks.cgi. Here the alphabetical listing provides more information than that on the FTP site, but the route to the FTP download site is more complex: one should click on the ‘RefSeq’ link for the bacterium of interest, and then on the resulting page click on ‘RefSeq FTP’ (see also Note 4).

2.2.1 gbk files

The file with the extension ‘.gbk’ in the section of the FTP site for a particular bacterium contains the nucleic acid sequence of its genome, and annotation of genes and other features. This is the file that is required for viewing the genome in BugView. There may, in fact, be several files with different RefSeq numbers (identifiers starting with ‘NC_’), the largest being the bacterial genome and the other(s) being plasmids associated with it. 

It is worth remarking that the RefSeq (Reference Sequence) number for a genome generally corresponds to the number on the ‘Accession’ line of its documentation, and is often referred to as the Accession number. In this chapter we shall use the term ‘RefSeq number’ throughout for consistency.

2.2.2 ptt files

Files with the extension ‘.ptt’ contain tabular information on each annotated gene, with columns available for, but not always furnished with, the COG (Classification of Orthogonal Groups) number and category (2). Because the COG category can be imported into BugView it is worth downloading the relatively small .ptt files corresponding in RefSeq number to the .gbk files one has downloaded in 2.2.1, above.

2.2.3 faa files

Files with the extension ‘.faa’ contain the amino acid sequences (in FastA format) for all the annotated genes of a genome. If one intends to use Blast to generate a genome Comparison file (section 3.1.3) one should download the .faa files corresponding in RefSeq number to the .gbk files one has downloaded in 2.2.1, above.

2.3 Optional Ancillary Software

2.3.1 Standalone Blast

Section 3.1.3.2 describes how to use a local installation of the program, Blast (3), to generate a BugView genome Comparison file. Standalone versions of Blast for various platforms (but not for Mac OS8/9) can be downloaded from http://www.ncbi.nlm.nih.gov/BLAST/download.shtml. Instructions for installation are included in the download, but the non-technical user will probably require assistance with the set-up.

2.3.2 gcfprep

To use standalone Blast to generate a BugView genome Comparison file it is necessary to perform successive comparisons of protein sequences. A Perl script to automate this, gcfprep, can be downloaded from http://www.gla.ac.uk/~dpl1n/BugView/bvdownload.html. This script has only been tested on standalone Blast running under Solaris, and may need modification to run on other platforms. 

2.3.3 BlastToGCF

Section 3.1.3.3 describes how to use a Grid-enabled web-accessible version of the program, Blast, to perform successive comparisons of the protein sequences encoded by the genes of two genomes. A small utility program, BlastToGCF, has been written to convert the output to a BugView genome Comparison file. Versions for different platforms are available for download from http://www.gla.ac.uk/~dpl1n/BugView/bvdownload.html.

3. Using BugView

3.1 Genome Comparison

3.1.1 An Introduction to the BugView Interface

Fig. 1 shows BugView after launching and loading files. Three regions of the interface can be distinguished: the menu bar, a control console consisting predominantly of named buttons, and the main genome display window, only the upper part of which can be seen in the figure. (This latter will be blank before any files have been loaded.) General operations can be accessed from menu items, and the Help menu (the position of which may differ from that in the illustration, depending upon the platform) gives access to systematic brief descriptions of the items in each of the menus. The controls in the console mainly operate on objects (genes etc.) in the display window. If no object is selected — as will be the case initially — most of the controls will be dimmed, indicating that they are unavailable. The operation of these controls is described in sections 3.1.4 and 3.1.5, below. Section 3.1.6 considers some additional controls for ‘power users’.

3.1.2 Processing Genbank files

1.
The first time you work on a genome in BugView you must convert one or more .gbk file, downloaded as described in 2.2.1, to BugView-format Data and Sequence files.

2.
Choose ‘Convert Genbank File’ from the File menu. 

3.
Wait while the conversion occurs, which may take a minute or two (see Note 5).

4.
When conversion is complete you will receive a message notifying you of the filenames of the Data and Sequence files generated. These are based on the RefSeq number of the genome, and are given the extensions ‘.gda’ and ‘.seq’, respectively.

5.
Now is a convenient time to import any COG information from the .ptt file downloaded as described in 2.2.2. Choose ‘Load COGs from .ptt File…’ from the ‘Load COGs’ sub-menu in the File menu. (This can be done subsequently, but if the menu choice is not available, see Note 6)

6.
A message will appear indicating how many COG categories have been assigned. If this is zero, it will reflect the absence of COG information in the .ptt file. If the .ptt file contained COG information, then those genes to which this information relates will have become colored according to a scheme to be found in the Help menu under ‘Category Colour Key’.

7.
Choose ‘Save File’ from the File menu to save the COG annotations.

8.
In subsequent sessions with BugView the Data and Sequence files are used, and the Genbank file is not required. Edits the user makes (such as assigning COG categories) will be saved to the Data file. (This separation from the Sequence file—which cannot be edited in BugView—accelerates saving changes to the Data file, and avoids possible corruption of the Sequence file.)

9.
Before performing a second conversion one is advised to unload loaded files. Choose ‘Unload All Files’, from the File menu.

3.1.3 Creating a Comparison file

A BugView Comparison file contains a user-defined list of gene Pairs for two genomes. There are three ways in which it can be created.

3.1.3.1 Creation within BugView

Because of the time involved in generating a large number of comparison Pairs manually, one would normally only create a Comparison file from within BugView when one just wished to compare a subset of genes within two genomes, or when automated creation (3.1.3.2 and 3.1.3.3) was not available.

1.
Load the Data (.gda) and Sequence (.seq) files (section 3.1.2) for the two genomes to be compared by choosing ‘Open Genome File’ from the File menu, followed by ‘Open Data File’ or ‘Open Sequence File’, as appropriate, from the submenu.

2.
Choose ‘New Comparison File’ from the File menu.

3.
You will be prompted for a name for the file to be generated, and will be able to navigate through your filespace to the directory in which you wish to save it. It is recommended that the file be saved to the same directory as the associated genome files, and that its name should reference the RefSeq numbers of these (see Note 7) and have the extension .gcf (e.g. NC_003112-NC_003116.gcf).

4.
A message will appear informing you that the Comparison file has been created. You should notice that, although the area between the genomes (where the comparison Pairs will appear) is not yet occupied, the labels on the right-hand genome have been re-oriented to the right (i.e. to the outside) so that they do not intrude upon this inner area.

5.
Addition of Pairs to the Comparison file is described in section 3.1.4.2. Whether or not one starts adding Pairs immediately, it is worth generating a project file at this stage (see Note 8).

3.1.3.2 Creation using standalone Blast

It is assumed that the user has downloaded (section 2.3.1), installed and tested standalone Blast according to the NCBI documentation, and also downloaded gcfprep (section 2.3.2). It should be emphasized that one is performing comparisons of the protein products of the annotated genes found in the .faa files (2.2.3), not comparisons of the nucleic acid sequences.

1.
Run the formatdb program included in the Blast download (see also Note 9) to generate databases of your genomes from the relevant .faa files. Check the ‘formatdb.log’ file for possible problems at this stage.

2.
Run the script gcfprep by typing its name and responding to the prompts. Comparison of two bacterial genomes might take up to an hour, depending on the speed of the machine, but an indication of progress is given every 50 comparisons. The output .gcf file lists the gi numbers of all inter-genome Pairs with an e-value less than 0.05 (or as specified by the user if the alternative gcfprepE is used.) A log file contains details of any proteins that were missed.

3.
BugView has several features that allow one to filter comparison Pairs on the basis of percentage identity, rather than e-value. To use these features, it is necessary for the percentage identities to be calculated within BugView. To do this, after the Comparison file (and the cognate genome files) has been loaded into BugView (see Note 10), one chooses ‘Update Pair Scores’ from the Pairs menu. After the update has been completed (see Note 11) one should remember to save.

3.1.3.3 Creation using GridBLAST

For those users who are not in a position to set up standalone Blast, web access to a BLAST grid service has been provided by BRIDGES, a UK e-Science project. This had just come into operation at the time of writing, and it is possible that some details of use (particularly the url) may have changed by the time of publication. (Check the BugView website.) Before starting, ensure that you have available the .faa files for at least one of the genomes that you wish to compare.

1.
Connect to http://cassini.nesc.gla.ac.uk:9081/wps/portal. (see Note 12)

2.
You are required to register before being able to use this Grid service. There is a small link — ‘Sign up’ — at the top right of the page for doing this.

3.
After registration you should click on ‘Log in’ at the extreme top right corner, when you will be taken to the login page. There you should enter your User ID and Password in the appropriate fields, and click on the ‘Log in’ button.

4.
On the page that appears, click on the blue ‘Computational Resources’ tab on the horizontal bar.

5.
Next click on ‘GRIDBLAST Job Submission’, which will take you to the page where you can run your Blast genome comparison.

6.
In the first two fields, respectively, enter a job name and, if you prefer not to wait while your job runs, your e-mail address for notification of completion.

7.
Clear the contents of the third field and leave it empty. Instead of pasting the large genome .faa file here, upload it from your filespace at the ‘Select input file’ option using the ‘Browse’ button. You should make a note of the RefSeq number of this file, and the fact that it will subsequently be referred to as the ‘Query’ genome.

8.
Choose the second genome from the list on the pull-down menu. The names of the genomes, rather than their RefSeq numbers, are listed on the menu, so you will need to check to reconcile these yourself, referring to the Genbank website if necessary (see section 2.2). Make a note of this RefSeq number as that of the ‘Database’ genome.

9.
None of the default values of the pull-down menus is appropriate. Carefully select the following:

Blast Program
blastp

e-value
0.1 or 0.01

word size
3

generate alignments
no

include gi numbers in output
yes

output format
txt

10. Click the button entitled ‘Submit Job’. It typically takes about ten minutes for a comparison of genomes with 2000 genes to run, generating an output file of about 5 Mb in size.

11.
The relevant information from this output file is converted to a BugView Comparison file using a small utility, BlastToGCF (section 2.3.3). Launch this, choose ‘Load Blast File’ from the File menu, and locate and load the GridBLAST output file. After a short delay you should receive a message that the file has been read, with an invitation to view the list of protein Pairs that has been generated. If all appears satisfactory at this stage, choose ‘Write gcf File’ from the file menu. You need to enter the RefSeq numbers of the ‘Query’ and ‘Database’ Genomes (as in sections 7 and 8, above) and then save with a suitable name and .gcf extension. The resulting file will now typically be only 50K in size.

3.1.4 Editing Comparison Pairs

Whether a Comparison file has been generated automatically, as in section 3.1.3.2 and 3.1.3.3, or from within BugView, it will generally be necessary to add or delete comparison Pairs on the basis of visual inspection or scientific knowledge. To illustrate how this is done we shall take as starting point the situation where an empty Comparison file has been constructed (3.1.3.1).

3.1.4.1 Locating and Editing Genes of Interest

When starting with an empty Comparison file it is likely that there are specific genes that one wishes to compare. One can use the ‘Find’ or ‘Search’ facilities to locate them.

1.
A ‘Find’ dialogue can be evoked by clicking the eponymous button on the console, or by using the standard keyboard shortcut (command-F or control-F, depending on platform). One can find a gene by ID (gi number), name, or product (see Note 13)—entering a gene name, such as ‘trpS’, might be a typical example. This example is likely to give a single ‘hit’ on each genome, with the first hit being selected and its name highlighted. Using control-G or command-G one can cycle through all the hits in the display window.

2.
In some genomes the gene names are unhelpfully designated as cds_1 etc. If the gi number of a gene of interest is unknown, attempting to locating it on the basis of its product will be one’s best option here. In this case the ‘Search’ facility (console button) is perhaps to be preferred. Thus, a term such as ‘polymerase’ might bring up a list of all RNA and DNA polymerase subunits etc., allowing one to choose ones of interest. As one selects different product names in the list, the corresponding genes are selected and their names highlighted in the display window (see Note 14).

3.
In order to inspect a gene of interest, one can use the ‘Focus On’ button in the console. This zooms the gene to the highest magnification at which it will fit into the display window. At this stage one may wish to decrease the zoom factor using the console slider in order to see the context of the gene. Clicking on the ‘Gene Info’ button in the console (or double-clicking on the gene) will open an information window for the gene. (Of particular interest for forming a Pair may be the gi number, see section 3.1.4.2.) One can change from the ‘Information’ view to the ‘DNA sequence’ and ‘protein translation’ views by clicking on the appropriate buttons (see Note 15).

4.
In cases where the genome is poorly annotated, one may wish to add one’s own annotations or change the name or gene-product information. This can be done by selecting the gene and clicking the ‘Edit Info’ button in the console (or transferring directly from the previous ‘Gene Info’ window by clicking the ‘Edit’ button). The gene category is edited separately by clicking the ‘Edit Category’ button in the console, and choosing from the categories listed. Edits are included in the .gda file after saving from the File menu.

3.1.4.2 Adding Pairs

We shall consider two different situations in which one would be adding a new Pair to the Comparison strip. The first is where one has identified the two genes from which one wishes to create a Pair.

1.
Usually one will first check the pairwise alignment of the two genes. Select one gene by clicking on it, and then click on the ‘Single’ button on the console in the ‘Pairwise Comparison’ group (Fig. 1). Paste the ID (gi number) of the second gene into the field marked ‘Query Gene ID’ and click ‘Start’. Local and Global pairwise alignments will be performed, with the Local alignment being displayed. Generally one’s scientific judgment will determine whether an alignment is significant or not. As a rough guide, our experience is that there is likely to be a significant similarity when the ‘Score’ is greater than about 120 (see Note 16).

2.
If one wishes to proceed to make a Pair, one clicks the ‘Make Pair’ button that becomes active after the comparison has run. This brings up an ‘Add Pair’ dialog with the gi numbers for the two genes already entered. (One can also invoke this dialog from the the ‘Add Pair’ button in the console after selecting one of the genes in the display window. In this case one would have to enter or paste the second gi number.) Click ‘OK’ to create the Pair.

3.
The two genes and the Comparison strip will be selected, and one may well wish to click the ‘Co-align’ button in the console to view them together in their respective genome contexts. This will often facilitate identifying other Pairs when one is working on a gene cluster.

4.
The new Pairs are included in the .gcf file after saving from the File menu.

The second situation to be considered is where one can locate a gene of interest on one genome, but searching by name or product does not identify a corresponding gene on the other genome.

1.
Select the gene of interest in the display window, and click on ‘Batch’ in the ‘Pairwise Comparison’ group of the console (Fig. 1). Click on the ‘Start’ button.

2.
Typically 2000 comparisons will take no more than a few minutes (see Note 17). The three best matches will be displayed, and one can choose from a pull-down menu which (if any) of these one wishes to make Pairs from, and then click the ‘Make Pair’ button. Thereafter one would proceed as in 3 and 4, above.

3.1.4.3 Deleting Pairs

One generally wishes to delete some biologically spurious Pairs from automatically aligned genomes.

1.
Select the alignment Pair one wishes to delete. This can be done by selecting either of the genes in the Pair or, better (but generally more difficult), the strip between them.

2.
Click the ‘Delete Pair’ button in the console.

3.
If one has selected the strip between Pairs, or a gene which has no other Pairs, a confirmation dialogue will appear. If one has selected a gene that is a member of more than one Pair, a list of Pairs will appear, from which one must chose. After the gi numbers of the Pair, the percentage identity (local alignment) is displayed in parentheses to help one distinguish between alignments of different quality.

3.1.5 Traversing and Reviewing Comparison Pairs

Generally after one has generated a genome alignment automatically one wishes to go through the genome, reviewing the comparison Pairs that have been assigned, and considering genes that appear not to have counterparts in the other genome. Three approaches to this are described.

3.1.5.1 Manual Traversal

In manual traversal one starts at the beginning of one genome and examines paired and unpaired genes, scrolling as one goes. Although straightforward, an example of this procedure is described to illustrate some of the facilities in BugView.

1.
Click on a gene near the ‘top’ of the first genome (or start from a known position using ‘Find’ or ‘Search’) and then click the ‘Focus On’ button in the console (Fig. 1). This zooms the gene to the highest magnification at which it will fit into the display window (Fig. 2 A).

2.
‘Click’ on the scrollbar ‘up triangle’ to scroll to the very start of the genome, even though it may not be evident that there is still ‘play’ here (Fig. 2 B).

3.
Select the first gene by clicking on it. If it is a member of a Pair the ‘Co-align’ button on the console will become enabled, if not it will remain dimmed.

4.
For the first gene that is a member of a Pair, click on the ‘Co-align’ button on the console. Fig. 2 C shows a typical result of such an alignment for two strains of Neisseria meningitidis (see Note 18). The first group of genes on the genome of one strain align to a group starting at gene 248 on the second strain. (The genomes are, of course circular, but the origin of replication is used as a reference point for the ‘start’.)

5.
One now scrolls down the genome. Using the scrollbar to do this can often be unsatisfactory for large genomes at high magnifications. In this case it is better to use the keyboard ‘up’ and ‘down’ arrows (which scroll half a window at a time). For even finer adjustment, one can use the mouse pointer—if one depresses the mouse within an area of the display window to the right of the genomes, the pointer changes to a ‘hand’, which can be used to scroll the window interactively by small amounts.

6.
As one scrolls, insertions or deletions can cause the alignment Pairs to diverge increasingly from horizontal. One can realign, as in 4, above, or, more conveniently, interactively using the mouse pointer with the ‘alt’ key depressed. (Here the cursor changes to a hand with the forefinger extended.)

7.
When one comes to the end of a homology block, one is advised to select a gene in this region and then zoom out using the slider on the console. Clicking on the ‘Centre’ button in the console will maintain the region of interest in the center of the display window as long as the zoom level is above 1.

8.
In the N. meningitidis comparison a second block of genes in the first strain can be seen to be aligned to those at the ‘start’ of the genome of the other strain, but in an inverted orientation—a very common situation (Fig. 3 A). To review this second block, first select a gene near the middle of it, then choose ‘Reverse Directions’ from the View menu, click on the ‘Co-align’ button (this gives the alignment shown in Fig. 3B), and then the ‘Focus On’ button. Scroll back to the start of the group and continue as before (Fig. 3C). If it is necessary to restore the original orientation of the genomes at any stage, this is done by choosing ‘Restore Directions’ (which will have replaced ‘Reverse Directions’) from the View menu. (The default alignment can be restored by clicking the ‘Revert’ button in the ‘Align Pair’ group on the console.)

3.1.5.2 The Traverse facilities

An alternative to manual traversal, or an adjunct to it, is to review separately the Pairs and the unpaired genes using the traverse facilities. This is probably of most interest for examining the unpaired genes, especially in the case of different strains of the same bacterium.

1.
To work with all the gene Pairs, choose ‘Traverse Pairs’ from the Pairs menu. In the dialogue box click the ‘load’ button. A list of paired genes will appear in the window. The Pairs can be traversed by scrolling or using the ‘up’ and ‘down’ arrow keys. A Pair selected in this window will also be selected in the genome display window, and can be co-aligned and centered without closing the traversal window.

2.
To review all the unpaired genes, choose ‘Traverse Unpaired Genes’ from the Pairs menu. The names of the unpaired genes from both genomes will appear in the window. Traversal is as for Pairs in 1, above.

3.1.5.3 Using the Matrix view

It can be difficult to keep track of one’s position in a genome while traversing gene Pairs from genomes in which the gene order has diverged significantly. Using the Matrix view in conjunction with the display view in the main window can help in this respect.

1.
Choose ‘Matrix Genome Comparison’ from the Diagram menu. A dot-matrix comparison of the genomes will be displayed (see Note 19). A typical example, in which each dot represents a homologous Pair, is presented in Fig. 4. Pairs with the same orientation follow a diagonal from top left to bottom right, whereas those with opposite orientation follow a diagonal from bottom left to top right (and are colored red for ease of identification).

2.
One can use the horizontal and vertical guideline tools to mark the blocks of related genes (or gaps), numbering them for reference with the text tool (see Note 20). The annotated matrix can be printed or saved as a graphic file.

3.
Having defined a particular region of alignment of the genomes, one can transfer to that region on the main genome display window. This is done by enclosing the region in a small rectangle using the selection tool in the Matrix display (‘#1’ in Fig. 4), and then clicking the ‘Transfer’ button. In the main window the region selected will be zoomed and, if possible (see Note 21), centered.

3.1.5.4 The Pair Display Range facility

In Fig. 4 it can be seen that there is a pull-down menu entitled ‘Identity Cutoff’. This allows one to restrict the display of the matrix comparison to Pairs, the percentage identity of which is greater or equal to the number selected (40% in this case). A similar way of filtering the Pairs to be displayed is available in the main window, and can be accessed by selecting ‘Set Pair Display Range’ from the Pair menu. This is more sophisticated than the option in the Matrix view as it allows one to set both upper and lower limits for display. The facility is useful for reviewing those automatically-generated Pairs which have a relatively low identity. The Pairs listed in the Pair Traversal window—3.1.5.2—also reflect this selection.

3.1.6 Further Aspects of the BugView Interface

In section 3.1.1 we described the general features of the BugView interface, and in this and subsequent sections the description of controls focused mainly on visible features—the menus and the console buttons etc. Although these controls are likely to be the main ones employed by users familiarizing themselves with BugView, they do involve frequent—and ultimately tedious—mouse movement. For users who have become proficient with the basic operation of BugView there are some extra controls for more efficient working (in addition to keyboard equivalents for some of the menu items).

3.1.6.1 Keyboard Control

It has already been mentioned (3.1.5.1) that one can scroll using the ‘up’ and ‘down’ arrows of the keyboard. There are also keyboard controls for zooming, focusing, centering and several other functions. These are listed in the ‘Mouse and Keyboard control’ item of the Help menu.

3.1.6.2 Context-sensitive menus

At any time pressing the right mouse button (control-pressing on the Macintosh platform) will invoke a pop-up menu (cf. Fig. 6), the contents of which are dependent on the position of the pointer. Of most interest are the menus available when the pointer is on a gene or a Pair, where the options available are roughly equivalent to those that are available from the console if the gene or Pair is selected. Their selection from the pop-up menu is obviously quicker than from the console, and is especially advantageous where an operation is being performed repeatedly on a set of genes or Pairs.

3.2 Internal Genome Structure

The information in the previous section (3.1), describing the use of BugView for visualizing genome comparisons, is in many cases also applicable to surveying the genes in a single genome. However, not yet mentioned are the specific facilities BugView provides for visualizing groups of genes of similar function—genes in pre-set categories or those defined by the user. These are dealt with in this section.

3.2.1 Pre-defined Gene Categories

The pre-defined categories to which genes may be automatically assigned using a suitable .ptt file (section 2.2.2), or manually with the ‘Edit Category’ control (3.1.4.1), have already been introduced. In fact, the categories in BugView extend the COG categorization—stable RNA genes have been added (and are assigned automatically when converting a Genbank file), and additional categories for virulence and for inactive genes are also included. The full list can be viewed by choosing ‘Category Colour Key’ from the Help menu.

3.2.2 Custom Gene Sets

Although the functional categories available in BugView cannot be modified by the user, it is possible to create custom sets that can be used in certain visualizations. This is not entirely straightforward, so a hypothetical example is described.

1.
Choose ‘Create Custom Set’ from the Diagram menu.

2.
Let us suppose one wishes to visualize genes associated with the function of RNA polymerase in N. meningitidis. If more than one genome is loaded, choose the genome of interest, and then enter the term ‘polymerase’ as ‘Search String’ and click the ‘Search’ button. 

3.
The results include not only RNA polymerases, but DNA polymerases and a polyA polymerase. Select each of the latter and click ‘Remove’.

4.
This decreases the list to eight entries, but does not include relevant terms such as ‘sigma’ and ‘rho’, which may occur in the absence of the term ‘polymerase’. The list is extended by searching for these terms (or previously identified known gene products) and removing any duplicates.

5.
One then types a name for the set (e.g. ‘RNApol’) and clicks the button ‘Create Set’. It is important to realize that at this stage the set is available for use in the current session, but must be saved to disc for use in subsequent sessions. This is done by selecting ‘Write Custom Set’ from the Diagram menu, selecting the appropriate submenu, and giving the set a name such as ‘RNApol.set’. The visualization of custom sets is described in section 3.3.3, below.

6.
The set can be loaded in a subsequent session by choosing ‘Load Set’ from the Diagram menu.

3.2.3 Finding Repeated Genes

It may be that one is interested in genes present in multiple copies, rather than those related by a specific function (3.3.2). If one can identify a member of such a gene family, one can perform pairwise alignments to search for other family members.

1.
Select the member of the gene family and click the ‘Internal’ button in the ‘Pairwise Comparison’ group on the console (Fig. 1).

2.
A dialogue box with a progress window will appear. Click ‘Start’.

3.
When all the comparisons have been performed, those above a preset threshold will be listed. (The default is 100, but this can be altered by choosing ‘Internal Comparison Filter’ in the Settings menu.) Of these, alignments for the best three (again customizable) will be displayed. Those of interest can be noted, their gene information edited, and a custom set constructed from them, as in 3.3.2.

3.2.4 Gene Category Displays

The genomic location of genes of different categories can be displayed in either horizontal or circular orientation.

3.2.4.1 Circular Display

This is obtained by choosing ‘Circular Diagram’ from the Diagram menu. An example is illustrated in Fig. 5, showing a format that is frequently employed in publications and presentations. Up to four different gene categories can be represented, including the custom sets of 3.3.2, and the strand on which a gene resides is indicated by whether the gene (represented as a short line) is outside or inside the conceptual circle traced by the genome. GC-content and GC-bias can also be represented. The diagram (as is true for the contents of the main genome display window) can be printed or saved as either a gif graphic (suitable for web use or slide presentation) or a PostScript file, which may be more suitable for publication (see Note 22).

3.2.4.2 Linear Display

The linear display is obtained by choosing ‘Linear Diagram’ from the Diagram menu. It was introduced primarily as a means of viewing the whole of a genome at a scale that allowed individual genes to be distinguishable and identifiable by color category. (The gene direction indication can be turned off in this view to make better use of the area available.) The names of individual genes are shown on ‘mouse over’, and clicking on an individual gene takes one to that gene in the main window. Alternatively one can view up to three categories of gene together in this display, which may be useful in certain situations.

3.3 Web Deployment

BugView differs from the web-based Java applet, Der Browser (4), from which it was developed, by being a desktop application and having gene-comparison features that the applet lacked. However after the original description of the BugView application (1) it was decided that it would be useful to provide an applet version—BugView/weB—to enable users to make web presentation of genome comparisons generated in the desktop application. This applet version is available from http://www.gla.ac.uk/~dpl1n/BugView/bvapplet.html, and is described for the first time below.

3.3.1 The Scope of BugView/weB

For security reasons web applets have restrictions placed upon them, with the result that the scope of BugView/weB is more limited than that of the BugView application.

1.
File read and write is not allowed. This means that the web author has to provide the files for the genomes and comparisons to be displayed, and the user is not able to edit Pairs, print (printing the web page may not work), or save the graphic view (except using screen capture software). Instructions for referencing BugView files from the web page are given in section 3.3.2.

2.
Menus are not allowed in applets. In the event, many of the menu items and some of the console button items are redundant in this context, so the console has been simplified (Fig. 6). The remaining functions on the console are for navigating the genomes and viewing information on genes and Pairs. To this end the controls for reversing directions and displaying GC-bias have been transferred from menu items to console buttons. (Although not mentioned previously, inclusion of GC-bias in the main display window is available by choosing ‘Display Other Features’ in the View menu of the application.)

3.
‘Help’ is available from the ‘?’ button in the console, although as a pop-up web page. Users may therefore need to be warned to disable pop-up blocking if they wish to use the ‘Help’ facility.

4.
Context-sensitive menus are still available, but their contents differ from those in the desktop application. In the absence of menus, and because of the pressure of space on the console, changing label preferences is offered on the menu when one right/control clicks outside a gene or Pair (Fig. 6).

5.
The size of files that can be loaded in the applet appears to be limited to about 1.5 Mb. Thus, one can only serve sequence files for small genomes such as the poxvirus genomes illustrated.

6.
Although the main interest in BugView/weB is for presenting the comparison of two genomes with multiple comparison Pairs, it is also possible to present a series of individual genomes side-by-side.

3.3.2 File organization and HTML mark-up

Fig. 7 shows the organization of supporting files in relation to the web page containing the applet. The BugView files are referenced within the <applet> tag as parameters, which can have values of ‘datan’, ‘seqn’ or ‘comparison’. The ‘n’ in ‘datan’ and ‘seqn’ represents an integer which must start at 1, followed by successive values—2, 3 etc.—without omissions. An example, being the markup for the comparison in Fig. 6, is:

<APPLET codebase ="bvfiles" code="BugView.class" archive = "BugView.jar" width="640" height="500">

<PARAM NAME="progressbar" VALUE="true">

<PARAM NAME ="data1" VALUE="bvfiles/NC_001559.gda">

<PARAM NAME ="sequence1" VALUE="bvfiles/NC_001559.seq">

<PARAM NAME ="data2" VALUE="bvfiles/NC_001611.gda">

<PARAM NAME ="sequence2" VALUE="bvfiles/NC_001611.seq">

<PARAM NAME ="comparison" VALUE="bvfiles/NC_001559-NC_001611.gcf">

You need Java to view this applet.

</APPLET>
where ‘bvfiles’ is the name of the directory (folder) in which the BugView files are located. The width and height can, of course, be altered to suit individual circumstances (although a narrower width will not accommodate the applet) and the ‘progressbar’ parameter is optional (and the bar itself is not displayed with older versions of Java). Web pages with the applet marked-up in this manner should have a ‘Transitional’ Document Type Definition (see Note 23).

4. Notes

1.
http://www.gla.ac.uk/~dpl1n/BugView/ is at Glasgow University, where the author is currently employed. Should he move elsewhere in the future he will attempt to ensure that users are forwarded appropriately from this url. However, in any case, either the software or redirection to a new url will be found in his private web space at http://www.q7design.demon.co.uk/BugView/.

2.
It would appear, for example, that at least 100 Mb of free RAM is needed to convert a Genbank file for a 5 Mbp genome. BugView will inform the user if there is insufficient memory to perform a file conversion.

3.
There is a bug in Java 1.4 for Mac OS X which prevents pasting into text areas and fields. At the time of writing this version of Java is standard for Mac OS X 10.4. However users can download and install Java 1.5 (in which this bug has been fixed) from the developer section of Apple’s website (http://Devworld.apple.com/java/).

4.
One can now also reach this page using the Entrez interface at the NCBI website to search for a particular genome (http://www.ncbi.nlm.nih.gov/gquery/).

5.
One can be deceived by the fact that the ‘wait cursor’ disappears after the first file (the Data file) has been created, even though creation of the second (the Sequence file) is still occurring and takes much longer to complete. If the program has insufficient memory available to process the file one will receive an error message. In this case it is worth quitting BugView, quitting all other unnecessary programs and trying again. On Mac OS8/9 freed memory can remain fragmented after quitting applications, so it is advisable to restart one’s computer before retrying.

6.
COG information can only be loaded when there is a single genome in the BugView window—if more than one genome has been loaded the menu item will appear dimmed. The reason for this is that the .ptt files contain no internal RefSeq numbers from which the program can determine to which genome they relate.

7.
If you are ever uncertain of the RefSeq numbers of the files that you have loaded into BugView, you can check them quickly by choosing ‘Genome and Pair Summaries’ from the View menu.

8.
A Project file can be generated at any time that all five files for a genome comparison (two .gda files, two .seq files and the .gcf file) are loaded into BugView. Choose ‘New Project File’ from the file menu, and save to the same directory as the associated Data, Sequence and Comparison files with a name that references their RefSeq numbers and has the extension .prj (e.g. NC_003112-NC_003116.prj). On subsequent occasions you will be able to open all five files at once by choosing ‘Open Project’ from the File menu.

9.
The appropriate way to run formatdb in this case is:

formatdb -i ‘RefSeqNo.faa’ -p T -o


where ‘RefSeqNo.faa’ should be replaced by the actual name of the input file.

10.
If the Comparison file fails to load it could be because the .faa file used to create it was from a later release of the genome than that used for the Data file. In this case the Comparison file might reference a gene not annotated in the earlier Data file, a situation that versions of BugView before 1.3.3 could not handle. The remedy is to upgrade to version 1.3.3 of BugView (or higher) in which the bug was fixed.

11.
Depending on the speed of the desktop machine, it may take an hour or so to update Pair scores (which is why one is given a chance to change one’s mind or interrupt the process). One is advised to turn off screen-savers or auto-sleep settings before starting.

12.
Because some institutions ban traffic from non-standard ports like 9081, it is intended eventually to change the url to http://cassini.nesc.gla.ac.uk/wps/portal. Certain features of the site require a modern version of Java, but this is not required for the actual Blast search. The choice of web browser should not be critical, but if one has problems with older browsers (e.g. Internet Explorer 5.1 for Macintosh) one is advised to try a more modern browser.

13.
The initial default category for Find and Search is ‘product’, but changes to reflect the most recent selection.

14.
Having located a gene of interest in the Search facility and having dispelled the dialogue box, it is all too easy to click inadvertently in the display area and lose the selection. This can be avoided by making sure the mouse cursor is over the console.

15.
If the ‘DNA’ and ‘Protein’ buttons are dimmed it will almost certainly be because the .gda file has been loaded without the .seq file.

16.
The local alignment (which only displays ‘good’ regions of similarity) is generally of more interest at this stage. The ‘Score’ is relative, being greater as the length of the protein increases. Thus, for two alignments with 100% identity, that for a short protein with will score less than that for a longer one. The percentage identity values are much cruder than the ‘Score’ as they are based simply on the number of matches and mismatches—they do not allow for the fact that similar amino acids are likely to be conserved, or that the alignment of rare amino acids is more significant than that of common ones.

17.
In a batch alignment, proteins will be skipped if they exceed the maximum size set in Preferences (this defaults to 1000 amino acids, but can be changed from the Settings menu). Such proteins will be listed in the output so that the user can repeat the comparison if he has available a machine with a sufficiently fast processor.

18.
These have RefSeq numbers NC_003112 and NC_003116, for those who wish to reproduce this example.

19.
It should be emphasized that this matrix is based on the user’s pre-assigned comparison Pairs—it is not generated from programmatic whole-genome comparison in BugView.

20.
One selects the horizontal or vertical tool and then clicks at the position one wishes the guideline to be. The position of the guideline may be adjusted by dragging the square handle, and the guideline may removed by alt-clicking the handle (the cursor should change from a cross-hair to an arrow first). One can edit text in a relatively crude manner after clicking on it.

21. Centering is not always possible when one gene is at one of the extremities of the genome in the display window. In such cases it should be easy enough to identify the region corresponding to that selected in the Matrix view.

22.
The user is cautioned that although the PostScript format provides scalable vector graphics—enabling one to obtain high quality text—the quality of the PostScript line graphics generated from BugView is limited by the resolution of the screen display because arithmetical ‘rounding’ occurs. PostScript graphics can be viewed in the free Ghostscript viewer for Unix and Windows, but are best opened and edited in a professional vector graphics application such as Adobe Illustrator.

23.
It is conceivable that some time in the future web browsers may no longer support the ‘Transitional’ <applet> tag. In such an eventuality revised markup instructions will be mounted on the BugView/weB web page. 

Acknowledgements

I thank Micha Bayer and Richard Sinnott of the BRIDGES project for setting up GridBLAST for use with BugView, and all those users who have stimulated improvements by providing feedback on the program.

References

1.
Leader, D. P. (2004) BugView: a browser for comparing genomes. Bioinformatics 20,129​130.

2.
Tatusov, R. L., Galperin, M. Y., Natale, D. A. and Koonin, E. V. (2000) Nucleic Acids Res. 28, 33​36.

3.
Altschul, S. F., Gish, W., Miller, W., Myers, E. W. and Lipman, D. J. (2000) J. Mol. Biol. 215, 403​410.

4.
Grigoriev, A., Levin, A. and Lehrach, H. (1998) Bioinformatics 14,252​–258.

Figure Legends

Fig. 1. General View of BugView. The console of control buttons can be seen with most in an active state. Above the console the menus are visible (here for Mac OS X—they will differ in detail for other platforms), and below a section of the display area, with part of the vertical scrollbar visible.

Fig. 2. Genome alignment in BugView. A. Uppermost visible part of left genome after clicking and focusing; B. The previous after clicking the top of the vertical scrollbar; C. Region of first gene in the left-hand genome after co-alignment with related gene in right-hand genome.

Fig. 3. Reversal of relative genome direction in BugView. A. View of first two blocks of related genes in the genomes of two strains of N. meningitidis showing the second block of genes with relatively reversed orientation below the first block of aligned genes with the same orientation. B. The previous after reversing directions and co-aligning. C. The previous after focusing on the first genes in the second block and decreasing the magnification slightly.

Fig. 4. View of the Matrix Genome Comparison window of BugView. The figure shows a comparison of two marine cyanobacterial genomes in which only Pairs with 40% local identity are displayed. A couple of annotations have been made, and a few horizontal and vertical guidelines have been added. These latter can be moved by their square handles or deleted by ‘alt-clicking’. A rectangular selection has been made with the selection tool (highlighted), and clicking on the ‘Transfer’ button would take one to the corresponding region in the main display window.

Fig. 5. View of the Circular Diagram window of BugView. The figure shows a display of different sets of genes of Streptococcus Pneumoniae arranged in concentric circles. The outer circle shows all genes (their directionality indicated by whether they are outside and inside an imaginary central diameter), the second shows one of the preset COG categories (in this case Transcription), and the third and fourth show custom categories generated by the user within BugView (RNA polymerases and Response Regulators, respectively). Plots of GC-content and GC-bias are also displayed.

Fig. 6. View of BugView/weB. A close-up view of part of a comparison of pox viruses is shown. The figure also illustrates a context-sensitive menu (invoked by right click—control-click on the Macintosh) and a parallel display of GC-bias. The view is of the applet portion of the web page only. Comparison with Fig. 1 allows one to see which console features have been removed and which menu features added to the console.

Fig. 7. Organization of BugView/weB files on a web server. Directories are represented as folders, and files as text documents. The example listed in the text is illustrated. The top directory is not named, but might typically be a user’s public_html directory on a Unix server. The index.html file (it need not have this name) is the web page in which the applet is marked up as in the text. A directory, bvfiles, contains all the other files associated with the applet. These are the five files generated by BugView, the Help folder and contents (which are included in the applet download) and the applet itself, BugView.jar, which is an archive of all the compiled files of the BugView/weB program. (If the name of the directory, bvfiles, is changed, the applet markup on the web page must be changed accordingly.)
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